QuantRocket

Market data subscription


#1

Hello,

I’m new to QR. I’ve been using Quantopian and Backtrader before and decide to give QR a try. It looks great so far.

I’m having an issue with subscribing market data.

  1. Subscribed to data on IB as follows

  2. Added ‘ARCA’ as my exchange on QR account page.

  3. Connect to IB

But I can’t subscribe to data and keep getting the following error:
2020-04-06 03:44:38 quantrocket.master: INFO Collecting ARCA STK listings from IB website
2020-04-06 03:44:40 quantrocket.master: WARNING No ARCA listings matching criteria found on IB website
I took a look at user guide and it seems I followed everything correctly.

Any help would be appreciated.

Thanks!


#2

Can you please provide the exact command you’re running and also the country where you’re located?


#3

Hi Brian,

Thanks for the response. I’m currently in Korea, but I signed up for IB as an US resident if it matters.
The followings are what I did.

  1. Account validation
    jupyter:/codeload $ quantrocket license get --force-refresh
    account:
    account_limit: 100000 USD
    concurrent_installs: 2
    exchanges:
  • ARCA
    licensekey:
    plan:
    currency: USD
    name: Bottle Rocket (Monthly)
    (I think this might be the issue since I’m not seeing account_balance_under_limit)
  1. IB login
    jupyter:/codeload $ quantrocket launchpad credentials ‘ibg1’ --paper
    status: successfully set ibg1 credentials

  2. ARCA data
    jupyter:/codeload $ quantrocket master collect --exchanges ‘ARCA’ --sec-types ‘ETF’
    status: the listing details will be collected asynchronously

Thanks for the awesome platform and very much looking forward to using it.

Stay safe!


#4

Nothing wrong with those commands. In the detailed logs you should see lines like the following:

Collecting listings from https://www.interactivebrokers.com/en/index.php?f=2222&exch=ARCA&showcategories=ETF&limit=100&page=1

Sometimes the URL might be different based on your geographical location, as IB sometimes redirects. Please manually navigate to the URL shown in your logs and you should see a table of stock listings. The software is apparently not finding anything on that page so I am wondering if there is a redirect happening. IB did make changes to their website in the last few days but I’m not able to reproduce your issue from the US or when tunneling to Japan (the closest place to Korea I can tunnel). Share what you find.


#5

Hi Brian,

Sorry for the delayed response. I was not able to login for the last few days cause I couldn’t get 2FA message from IB.

I just tried again, and I was able to login and get the market data!

I used exactly the same command, and not sure why it wasn’t working lol

Meanwhile, with regards to the URL, it seems I’m redirected to HK site.
Collecting listings from https://www.interactivebrokers.com.hk/en/home.php/en/index.php?f=2222&exch=ARCA&showcategories=ETF&limit=100&page=1

When I access the IB website, I’m getting this URL though.
https://www.interactivebrokers.com.au/en/home.php

Thanks for your help!


#6

I am encountering a similar error. On comparing the URLs from the logs and on the IB website, there’s a difference:
from logs,

https://www.interactivebrokers.co.in/en/home.php/en/index.php?f=2222&exch=NSE&showcategories=STK&limit=100&page=1

from IB website,

https://www.interactivebrokers.com/en/index.php?f=2222&exch=nse&showcategories=STK&limit=100&page=1

There’s an additional en/home.php path in quantrocket logs.
This is from cloud deployment. It worked fine with local deployment other day.


#7

Hi Sunny, I think it’s because of geo issues. You should be able to get data if you access from US IP via VPN. That’s what I’m doing (I’m based in Korea) Hope this helps.


#8

Thanks Jun.

I was able to get it use right URL by deploying in US region. Earlier I deployed in Mumbai region, but the domain was taking it through US region I think. Now that both the deployment and domain are in US region, it’s using the right URL.

Using VPN is a good idea. I wonder how much latency would it add against directly deploying in a US region.