QuantRocket

Connection pool is full, discarding connection. Cloud Jupyter Notebook won't connect


#1

Hey Brian,

I read this post. Here..

Here are my variations. I already have a local deployment under cd ~/quantrocket so I made a new folder named mkdir quantrocket_cloud then ran:
curl 'https://www.quantrocket.com/composefiles/latest/cloud/docker-compose.yml' -o docker-compose.yml
I then set the HOUSTON environment variables as you mentioned in the cloud OSx installation guide.

Eventually I run:

  1. cd quantrocket_cloud
  2. docker-compose -p quantrocket_cloud up -d

I still get:
image

Then I check docker-compose logs houston

image
image

I’ve only omitted the specific URL I used to create the A Record in the pictures. It looks like everything went through but after trying https://quantrocket.MYDOMAIN.com I get a failed to connect.

This is the creation of the EC2 I used (named it quantrocket1 because I already have quantrocket in apparently):
docker-machine create --driver amazonec2 --amazonec2-access-key XXXXXXX --amazonec2-secret-key XXXXXXX --amazonec2-open-port 80 --amazonec2-open-port 443 --amazonec2-instance-type t2.large --amazonec2-region us-east-1 --amazonec2-root-size 200 quantrocket1


#2

I ended up running the below and got into the quantrocket.MYDOMAIN.com with HOUSTON username & password:

  • eval $(docker-machine env quantrocket1)
  • docker-compose -p quantrocket_cloud up -d

Note I already had an IAM key named quantrocket when I originally made the EC2 Instance, thus I made a new one named quantrocket1.

I thought I just had it, but I can’t seem to run anything once I’m in. Just starts then quits (and no syntax highlighting):


Close, but still not sure why the Jupyter Notebook or demos won’t run.


#4

@Brian SOVLED but still have questions.

Started the steps and made a static name, quantrocket1 for the EC2 instance and folder. I also created an Elastic IP on AWS to associate with the A Record.
After that I followed all instructions with the eventual docker-compose -p quantrocket1 up -d.
Everything ran fine, but I still got the WARNING: Connection pool is full, discarding connection.

Except this time I went to my quantrocket.MYDOMAIN.com in GOOGLE CHROME and then I was able to run simple commands. In Safari I still can’t get it to jive.

GOOGLE CHROME

SAFARI


#5

It’s pretty hard to follow what you’ve done and what you’re still experiencing, but as far as Safari I would try reloading the brower, restarting the kernel, and/or restarting the jupyter service. Doesn’t seem like it should be anything more than that.


#6

Hi Brian,

I’ve tried the above mentioned ideas. I even close down docker and started it back up. Here is what I see.

Safari:

Google Chrome: