QuantRocket

Amazon S3 backup


#1

I followed the guide and tried to push database to S3, but I seem to be getting the following error.

quantrocket_db_1|Traceback (most recent call last):
quantrocket_db_1| File “sym://uwsgidecorators_py”, line 194, in mule_msg_dispatcher
quantrocket_db_1|_pickle.UnpicklingError: pickle data was truncated

What am I missing?
Thank you.


#2

Is this error repeatable? I haven’t seen it before but from the nature of it, it seems like it would be transient. (The names of the databases get pickled en route to being pushed to S3, so seemingly there was an error unpickling the database names.)


#3

It is repeatable and s3push keeps erroring-out.
The database are not corrupt and I can locally back up and (using other functions) push to S3, so it does not look like the database or data issue either.
Any Python library, perhaps, missing?


#4

Does the problem persist if you re-create (not just restart) the container? If so, does it happen on all your databases or only certain ones? What is the name of a specific database that this affects? It would be helpful to also provide the exact command you are running and the flightlog output preceding the traceback.


#5

The problem persists after re-create (I also just upgraded to 1.8.0).
The problem is also specific to ‘history’ databases. All other databases are pushed to S3 just fine (using --services param).

Below is the flightlog output when I run

quantrocket db s3push --services ‘history’

Other than sizes generally bigger than other databases, most of the history databases contain “-”, e.g. “quantrocket.history.tvix-10min-afternoon.sqlite”

Would this be the cause of the problem?


#6

I re-created all the history databases and pushed them to S3, which worked fine, so it looks like one or more history databases had some problems.